gmc forums   gmc forums
Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Yukon Forum

GMC Yukon Forum Forum for discussions regarding the GMC Yukon


ATTENTION: We're looking for moderators. Is anyone interested?
GMC Forum: yukon won't shift into 3rd
Reply
 
Thread Tools
  #1  
Old 03-04-2011, 08:04 AM
kboukari kboukari is offline
Junior Member
 
Join Date: Mar 2011
Posts: 0
Default yukon won't shift into 3rd

I was driving my yukon at about 60mph when suddenly the RPMs jumped and the engine got really loud. I slowed down and could not get the truck to go beyond 2nd gear. It shifts just fine into Reverse, 1st and 2nd, but then the RPMs jump when it is supposed to go to 3rd gear. I can get it to go into third gear if I push it pretty hard, but not easily. checked the transmission fluid, and it was low. The dash pannel never told me it was low on fluid and the thermostat for the transmission never showed it above normal range. The speedomoter has not worked for about a year now. It slowly went out and I just assumed it was the motor for the speedomoter, as this is a very common thing for GMC. The oil gauage works, but it stuck in the wrong range. It goes from max to beyond the max line, but still fluxuates. The other gauges work fine. I have obviously put more transmission fluid in it, but that didn't help. I have done some research and some things suggest the VSS, which I have not tried. Can anyone please help who may know why the truck is doing this.
Reply With Quote

  #2  
Old 07-10-2011, 11:55 PM
Monsolo Monsolo is offline
Junior Member
 
Join Date: Jul 2011
Location: Indianapolis, IN
Posts: 17
Default

Mine's doing the exact same thing... I hope I get an answer faster than you did! Jeez, you didn't get an answer AT ALL!!

Come on, guys! This is supposed to be a HELPFUL forum! No disrespect to everyone but COME ON!!!!
Reply With Quote
  #3  
Old 07-12-2011, 04:58 PM
happy 2011 happy 2011 is offline
Senior Member
 
Join Date: Apr 2011
Location: new hampshire
Posts: 540
Default

well the speed sensor some times can cause this problem. It happens just like you said 1st 2nd ok push for 3rd and it will go some times. thake it to a honest trans shop or the dealer and tell them you had this happen before and think it's the speed sensor. That way it will put a bug in the techs ear to check bthe sensor so you don't buy a unneeded tranny.

Good luck
Reply With Quote
  #4  
Old 07-14-2011, 07:45 AM
GMC Customer Service GMC Customer Service is offline
AUTHORIZED VENDOR
AUTHORIZED VENDOR
 
Join Date: Mar 2010
Location: Michigan
Posts: 570
Default

Sorry to hear about what’s going on with your Yukon, Monsolo. It’s been a few days since you posted this. Have you made any progress with this concern? Are you thinking about taking your vehicle to the dealer at all or handling this on your own?

Thanks,
Laura
GM Customer Service
Reply With Quote
  #5  
Old 11-23-2012, 08:51 PM
raymond651 raymond651 is offline
Junior Member
 
Join Date: Nov 2012
Location: Louisiana
Posts: 5
Default Yukon transmission

I hope all came out okay with the "possessed" transmission you described in your post. Can you let me know how it was checked and fixed? Was it the Speed sensor?

I have a 2003 GMC Yukon that I bought new and my soon-to-be-ex-wife drove the first 7 years of our owning it, but I drive now. It has about 138K mi. on it and it has truly been the best vehicle I have ever owned, hands-down! Now that I just jinxed myself, I wanted to comment on the Transmission.
Lately, I've noticed that when I come to a stop at a red light or stop sign and not take my foot off the brake pedal to roll a little bit while stopped, when i do take my foot off to press the accelerator and go, I hear the transmission bang into gear right when I lift my foot off the brake pedal. It's either downshifting into first of disengaging from whatever gear it was in at my stop. I guess this is a slight "slip" in the tranny! If, while I am waiting for the light to turn green, I lift my foot off the brake pedal to slightly roll, I hear it then and won't hear/feel it upon taking off. Anyone else relate to this?
Reply With Quote
  #6  
Old 11-25-2012, 05:07 PM
megmusgrove megmusgrove is offline
Junior Member
 
Join Date: Nov 2012
Posts: 3
Default

My 04 is doing the same thing! It was fine one morning, then in the afternoon it started shifting a little funny . . .got the oil changed and filled up with gas so I could add some Lucas Oil and barely made it up the mountain to get home. After working it to get up the last steep bit I limped it home while it was telling me TRANSMISSION HOT. Since then I haven't been able to get it to shift into 3rd and I don't dare drive it off the mountain. I've put Lucas Stop Slip in it and that didn't help. I've already had the transmission rebuilt once as reverse was going out. That was about 3 years ago. I'm afraid if I take it to a shop they're just going to say it needs rebuilding. I just can't fathom the thought of rebuilding it twice in the same vehicle!! (And had to do the same in previous one ugh!) Any word on what it is and how to fix it without rebuilding???
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 06:22 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2014 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

No special deals available at this time...