gmc forums   gmc forums
Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Sierra Forum

GMC Sierra Forum Forum for discussions regarding the GMC Sierra


ATTENTION: We're looking for moderators. Is anyone interested?
GMC Forum: 2001 Safari.4.3.....wont start
Reply
 
Thread Tools
  #1  
Old 09-22-2011, 11:29 AM
Willstox Willstox is offline
Junior Member
 
Join Date: Sep 2011
Location: Ofallon, Missouri
Posts: 13
Default 2001 Safari.4.3.....wont start

I posted once but never showed up? My question is.........do the safari's get vapor locked? My van ran fine, filled the tank up, went 5 miles down the road and it just shut down? It turns over just fine, I checked the fuel pump and it is fine, I turn the motor over and it just about starts but it wont? This happened once before and after trying to start it several times it finally started. What could be the cause of this? 2001 GMC 4.3 Safari.

Note: If I sit in the van, turn the key on several time's....to make sure the fuel pump is sending fuel......it almost starts???

Up date: I took the MAP sensor off and cleaned it, had to put the battery charger on it.....did not start...just makes no since how it will almost start???

UPDATE: I am getting a code...P1683....anyone know what these means and how to correct it?

Last edited by Willstox; 09-22-2011 at 03:51 PM.
Reply With Quote

  #2  
Old 09-22-2011, 04:53 PM
happy 2011 happy 2011 is offline
Senior Member
 
Join Date: Apr 2011
Location: new hampshire
Posts: 540
Default

sounds like lack of fuel pressure. Just becaues the pump runs does not mean you have fuel or fuel pressure.

Check the pressure with a gauge
Reply With Quote
  #3  
Old 09-22-2011, 05:17 PM
Willstox Willstox is offline
Junior Member
 
Join Date: Sep 2011
Location: Ofallon, Missouri
Posts: 13
Default

How hard is it to change the fluid presure switch?
Reply With Quote
  #4  
Old 09-22-2011, 07:26 PM
shadyowl2 shadyowl2 is offline
Junior Member
 
Join Date: Sep 2011
Location: Jersey
Posts: 11
Default

The code p1683 is an error in the ecm. The Eraseable programable read only memory in the computer. It can't read the data in the computer. That is the cause of the no start. The dealer must replace the computer and flash the new one
Reply With Quote
  #5  
Old 09-22-2011, 07:38 PM
Willstox Willstox is offline
Junior Member
 
Join Date: Sep 2011
Location: Ofallon, Missouri
Posts: 13
Default

Thank you Shadyowl, thats what I was looking for.

Again, Thank you.
Reply With Quote
  #6  
Old 09-25-2011, 06:00 PM
shadyowl2 shadyowl2 is offline
Junior Member
 
Join Date: Sep 2011
Location: Jersey
Posts: 11
Default

There is one other thing you could check too. Make sure your getting spark to the plugs. These 4.3's were also known for the dist cap's cross firing and causing a no start condition. That will tell you definately. This code is a known problem in the newer GM'S for no starts.
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2014 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

No special deals available at this time...