gmc forums   gmc forums
Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Canyon Forum

GMC Canyon Forum Forum for discussions regarding the GMC Canyon


ATTENTION: We're looking for moderators. Is anyone interested?
GMC Forum: I HAVE A 2004 GMC CANYON the heater blower quit working on the first 3 speeds...
Reply
 
Thread Tools
  #1  
Old 11-26-2008, 03:49 PM
gear jammer gear jammer is offline
Junior Member
 
Join Date: Nov 2008
Posts: 1
Default I HAVE A 2004 GMC CANYON the heater blower quit working on the first 3 speeds...

...but still works on high speed? what would cause this?
__________________
Powered by Yahoo! Answers
Reply With Quote

  #2  
Old 11-18-2012, 02:02 PM
leboo leboo is offline
Junior Member
 
Join Date: Nov 2012
Posts: 2
Default blower motor

Same thing happened to me, change the blower switch under dash for motor, i thought the motor was going bad its just the switch
Reply With Quote
  #3  
Old 04-15-2013, 12:43 PM
acfd788 acfd788 is offline
Junior Member
 
Join Date: Apr 2013
Posts: 3
Default blower motor

same thing happened to me you need to find the ground blocks under the hood that is what is causing it I went through about 5 blower motors before i figured it out you need to clean the ground blocks and make sure they are touching clean metal and it will stop doing that.
Reply With Quote
  #4  
Old 12-11-2013, 09:00 PM
ducdude ducdude is offline
Junior Member
 
Join Date: Dec 2013
Posts: 1
Smile Bad Blower switch?

Quote:
Originally Posted by acfd788 View Post
same thing happened to me you need to find the ground blocks under the hood that is what is causing it I went through about 5 blower motors before i figured it out you need to clean the ground blocks and make sure they are touching clean metal and it will stop doing that.
Thanks,
OK I will bite ....where are the grounding blocks ?? I have a 98 Sonoma and the fan runs on level 3 and that is it..Would love to get it fixed..

Thanks Eric
Reply With Quote
  #5  
Old 07-06-2014, 08:16 PM
94offroad 94offroad is offline
Junior Member
 
Join Date: Jul 2014
Location: north central montana
Posts: 2
Default

its not the switch but the blower motor speed resistor set, my 04 Colorado did the same thing
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 11:35 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2014 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

No special deals available at this time...