gmc forums   gmc forums
Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Sierra Forum

GMC Sierra Forum Forum for discussions regarding the GMC Sierra


ATTENTION: We're looking for moderators. Is anyone interested?
GMC Forum: 4 wheel drive will not engage.
Reply
 
Thread Tools
  #1  
Old 11-18-2011, 09:40 AM
Steph35 Steph35 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 3
Default 4 wheel drive will not engage.

Hey all, I'm new and I have this problem. I push the button to engage the 4x4 and I hear the actuator but I have no power going to my front. What could it be?? P.S. I have a 2002 Sierra.

Last edited by Steph35; 11-18-2011 at 09:54 AM.
Reply With Quote

  #2  
Old 11-18-2011, 10:47 AM
Z15 Z15 is offline
Senior Member
 
Join Date: Jun 2010
Location: Michigan
Posts: 443
Default

I don't know what you problem may be BUT I do know this. The push dash switch has been a big problem on 1999-2007 style trucks. I had a 99, 01 and 04 and each and every one had the original dash switch replaced under warranty. They were made by the infamous Delphi corp which was using shoddy parts from the far east in producing many GM electronic parts, switches, instrument clusters and the like.

I would be shocked if you walked into any GM dealer in N.A. and they not have a switch in stock, its that bad a problem.

There are also 2 other electronic components that control the 4x4 so the switch would be a less expensive of the 3.
Reply With Quote
  #3  
Old 11-19-2011, 04:24 PM
Steph35 Steph35 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 3
Default

Thanks Z15. I checked out the electronics on the push buttons and they seem to be in good shape so I went ahead and ordered a front axle actuator. I'll try and replace that and if that is not the problem, I will re-post.
Reply With Quote
  #4  
Old 11-30-2011, 07:36 AM
Steph35 Steph35 is offline
Junior Member
 
Join Date: Nov 2011
Posts: 3
Angry tried it and doesn't work

Well, I bought a new actuator and installed it. I can hear it when it engages and disengages however, this morning, woke up to some snow and tried it...no go. I still have not power getting to the front. What could be the problem now???? Pushbuttons are good, new actuator that actuates so is it the internals???? Do I bite the bullet and bring it in??
Thanks
Reply With Quote
  #5  
Old 01-18-2012, 06:09 PM
jmf jmf is offline
Junior Member
 
Join Date: Jan 2012
Posts: 9
Default

I am having the same issue on a 94 Sonoma, lights work, I hear clicking but no front wheel drive ???
Reply With Quote
  #6  
Old 01-18-2012, 10:04 PM
jmf jmf is offline
Junior Member
 
Join Date: Jan 2012
Posts: 9
Default

I took out the battery and tray to get access to the Actuator, it was totally shot, I pulled the cable manually and it worked, question can I leave the cable in the pulled out position for now, and can I drive it in 2WD and 4wd using the dash buttons as normal until I get another actuator, or do I have to release the cable at any specific time, answers greatly appreciated.
Reply With Quote
  #7  
Old 01-19-2012, 07:44 PM
Molson02536 Molson02536 is offline
Senior Member
 
Join Date: Dec 2009
Location: K/W Ontario Canada
Posts: 3,095
Send a message via AIM to Molson02536 Send a message via Yahoo to Molson02536
Cool

Quote:
Originally Posted by jmf View Post
I took out the battery and tray to get access to the Actuator, it was totally shot, I pulled the cable manually and it worked, question can I leave the cable in the pulled out position for now, and can I drive it in 2WD and 4wd using the dash buttons as normal until I get another actuator, or do I have to release the cable at any specific time, answers greatly appreciated.
You should be fine. My Jimmy had the same issues but was in the locked position from a bad vacuum switch. It was like for for most of the winter months a few times and it ran fine as long as I service the front differentials.

Since then i have turned my Jimmy in to a AWD by replacing the transfer-case from a AWD Safari and have the front differential locked all the time.

Hope this helps and keep us posted.

Molson02536
Reply With Quote
  #8  
Old 01-19-2012, 11:45 PM
jmf jmf is offline
Junior Member
 
Join Date: Jan 2012
Posts: 9
Default

Thanks, Molson02536
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 09:39 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2014 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

No special deals available at this time...