Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!

gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles No Longer In Production > GMC Jimmy Forum

Advertisements
suspension parts, shocks, struts and more

cars connected social network cars connected social networking app for ios cars connected social networking app for android






Notices

GMC Jimmy Forum Forum for discussions regarding the GMC Jimmy


GMC Forum: 2000 GMC Jimmy Start Problems
Reply
 
Thread Tools
  #1  
Old 10-27-2017, 11:05 AM
Kess Kess is offline
Junior Member
Drives a GMC Truck
 
Join Date: Oct 2017
Posts: 5
Unhappy 2000 GMC Jimmy Start Problems

I have a 2000 GMC Jimmy with 129K on it, 4.3 Vortec engine. Start fine if sitting for a few days, even on cold mornings, but after driving it for a few miles and letting it sit for a while, it seems to not want to start, cranks, but like no fire or maybe a fuel problem. Pretty sure the fuel pump as benn replaced recently as I just bought it recently. It runs fine on the road, idles fine, no missing or rough idle, shifts great. Looks as if the dist. has been replaced, not sure when or if the plugs and wires have been replaced, but seems to run good.
Just a starting problem, which is pretty common on these 4.3 Vortec engines from what I read. Most point to the Spider fuel injections system, meaning the fuel regulator common problem, but don't know if it has been replaced or not, probably not. Had " check engine soon" come on, I replaced the EVC Selonoid on top fo engine and cleaned the MAS and new air cleaner (old one was not that bad), Just that crazy start problem, but starts fine after sitting all night or all week-end, just has problem after it runs a few miles and you get back in to start it and it just cranks. All lights seem fine, not codes...

Thanks
Reply With Quote

  #2  
Old 11-09-2017, 10:00 AM
GMC Forum GMC Forum is offline
Administrator
Drives a nothing at the moment...
 
Join Date: Nov 2008
Location: Royal Palm Beach, Florida
Posts: 676
Default

Welcome aboard! And thank you for signing up... Moving this to the Jimmy section for hopefully more attention...
__________________
Have an iPhone or Android? Then you can be connected with everything automotive in your area.
Download the Cars Connected app for your iPhone or Android device today!



Get your next GMC for the lowest price possible! Go to TrueCar.com first!
Reply With Quote
  #3  
Old 11-26-2017, 02:55 PM
Jason6937 Jason6937 is offline
Junior Member
Drives a GMC Truck
 
Join Date: Dec 2016
Posts: 19
Default

Do you have spark and/or fuel when this happens? Fuel pressure should be around 60PSI
Reply With Quote
  #4  
Old 12-02-2017, 12:04 PM
Kess Kess is offline
Junior Member
Drives a GMC Truck
 
Join Date: Oct 2017
Posts: 5
Default 2000 GMC Jimmy 4.3 Vortec, 129K miles

Yes, have good fuel pressure, tested around 61 psi, holds for over an hour.
Fuel pump replaced, selonoid valve back at tank replaced,new wires, plugs, dist. checked and button all OK. MAS cleaned, only won't start after warm,,starts in milliseconds when first try when cold..
Can cool down PCM (Computer), and it starts right up, or in heating the Computer, it won't start. Have sent Computer off to A-1 for rebuld, rec'vd back and same problem. Am wondering if they did a thermal test on it or just checked it cold? Think will send back to then for another test with mention to heat it up first.
It runs just fine once running,,no problems at all..just starting problem when you run it a little and try to restart. Am thinking Spider is Ok since did fuel pressure test and it held pressure for an hour or more. Anybody out there that thinks it may be the PCM computer?
Have asked mechanic to test the cold start sensor,,he seems to think it is Ok,,also, have read where a bad ignition switch can cause hard starting? but only does this when warm up a bit.
Fustrated!
Reply With Quote
  #5  
Old 12-05-2017, 12:03 PM
Kess Kess is offline
Junior Member
Drives a GMC Truck
 
Join Date: Oct 2017
Posts: 5
Default

When my 4.3 Vortech engine is cold, it starts in milliseconds, but after warm, hard starting prevails...I can apply some heat to the PCM computer module when motor is cold, and I experience hard starting issue. Makes me think PCM, might be going bad...It runs fine after it starts, no missing or missfireing,
I have checked fuel pressure, and am getting around 61 and it holds that for A little over an hour, so am assuming spider is OK,,BUT NOT REAL SURE, and do not know if it has been replaced, but don't believe so..SUv ONLY HAS 129k MILES ON IT. Think I NEED TO REPLACE SPIDER?

Anyone else out there have this same problem? My Jimmy is a 2000 model with 4.3 Vortec engine.
At wits end...
Reply With Quote
  #6  
Old 12-16-2017, 12:07 PM
Jason6937 Jason6937 is offline
Junior Member
Drives a GMC Truck
 
Join Date: Dec 2016
Posts: 19
Default

I'm starting to think that it might be the fuel trim not functioning along with temperature sensors
Reply With Quote
Reply
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:01 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.