Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!


gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles No Longer In Production > GMC Jimmy Forum

Advertisements
cars connected social network






GMC Jimmy Forum Forum for discussions regarding the GMC Jimmy


GMC Forum: No spark from coil when hot
Reply
 
Thread Tools
  #1  
Old 10-16-2018, 05:57 AM
Blackfeather Blackfeather is offline
Junior Member
Drives a GMC Truck
 
Join Date: Oct 2018
Posts: 1
Default No spark from coil when hot

I picked up a 94 jimmy with 4.3 vortex from an older gentleman on sunday. Only problem so I was told was the positive battery cable. Replaced with a new cable and everything was right with the world. Truck fired up and ran and drove absolutely great. It idled for about 5 minutes and I drive it approximately 5 miles. I pulled it up in front of the house so the kids could clean it out and wash it and that's where it all went wrong. The girls wanted to drive it down the lane so they hopped in and nothing. Battery was dead when I got it and it didn't take a charge. Threw another battery in and it just cranked and cranked but would not start. I checked fuel pressure and it was good to go. I pulled the coil wire off and I had absolutely nothing. I have a parts truck so after I checked to see that I had power going onto the coil with key on I proceeded to swap the coil with a known good one. Still nothing! So at the point i figured it had to be the ignition module so i robbed the parts truck and still nothing with another icm. So fast forward to today, i get home and hit the key and low and behold it instantly fires off. I bought a brand new ICM today so i naturally assumed that was the problem now that it runs with the engine completely cold. After installing it i hoped in and drove it about 10 miles and before I could make it back home it stalled out. It forced right back up but stalled speraticaly and then started surging while idlingin park and would stall completely when put in gear. Then once again it will not start and no spark from coil. I swapped out both coolant temp sensors because I've had that happen on my 5.7 vortec but no such luck. I still have power to coil but zero spark after it was good and hot. I have had it running with 3 different ignition control modules so I'm pretty certain that is not the issue. It has ran with 2 different coils with the same problem. I am lost as to where to go from here. I picked this up so the kids wouldn't have to walk almost 2 miles to the bus and now I've got a new lawn ornament instead
Reply With Quote

Reply
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7. The Kia Telluride is a mid-size SUV similar to the BMW X5...