Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!


gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Yukon Forum

Advertisements
cars connected social network






GMC Yukon Forum Forum for discussions regarding the GMC Yukon


GMC Forum: mysterious problem??? 08 Yukon denali XL
Reply
 
Thread Tools
  #1  
Old 01-15-2019, 06:20 PM
jsoda jsoda is offline
Junior Member
Drives a GMC Truck
 
Join Date: Jan 2019
Posts: 2
Default mysterious problem??? 08 Yukon denali XL

Hello! I have an 08' Yukon denali XL I have been experiencing an issue ONLY while the car is in drive and ONLY from a cold start and while outside temperatures are very cold as well, like freezing temps. When I start my car and drive it immediately, the first couple times I come to a complete stop, the car does not stop as it normally does, it will come to a stop but rolls a little past where it should and as the car stops, the idle gets super rough and usually the car will completely stall out. It re-starts right after. The car will do this 3-4 times and then won't do it again until the next time I drive it from a cold start again and in cold temps outside. We were told this was a bad solenoid that was inside the transmission. We got 2 other opinions and were told this was a bad throttle body-also had a code suggesting this I believe. After having the throttle body replaced, the car seemed fixed for approximately 4-5 weeks. Now the car is doing the exact thing again. Please help!!!
Reply With Quote

  #2  
Old 01-27-2019, 09:19 AM
jsoda jsoda is offline
Junior Member
Drives a GMC Truck
 
Join Date: Jan 2019
Posts: 2
Default Additional symptom??

I just wanted to add some information that may or may not be important...I have also noticed lately, that sometimes when I go to accelerate after already driving on the road, coasting and then press on the gas petal again...the car doesn't immediately accelerate, it bogs down, almost like a choking sensation and then it will accelerate. I'm not sure if this has anything to do with my big problem, but it never used to do this. I just started noticing this right after having a new throttle body installed. ?????
Reply With Quote
Reply

Tags
brakes failing, cold start, stalling
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:07 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.