Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!


gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles No Longer In Production > GMC Envoy Forum

Advertisements
cars connected social network






GMC Envoy Forum Forum for discussions regarding the GMC Envoy


GMC Forum: 4wd issues :/
Reply
 
Thread Tools
  #1  
Old 06-08-2014, 09:46 PM
wurthit4660 wurthit4660 is offline
Junior Member
Drives a
 
Join Date: Jun 2014
Posts: 4
Question 4wd issues :/

New to the Gmc world so go easy on me... just picked up an 02' envoy sle, when I go to put it in 4wd low, high, or AWD I can hear what seems to be it engaging, however the service 4wd light comes on. Also when in one of the
4wd positions the light blinks (not sure if that is the norm or an indicator of something wrong). when I had it in 4wd low only my back tires spun in really muddy conditions. When I turn the vehicle off the service 4wd light goes off and stays off when the vehicle is re-started. service light only coming on when I attempt to use any of the 4wd options.

So is this a sign that I need a new 4wd transfer shift motor? or is it a different problem? Could use some help on this one thanks in advance....
Reply With Quote

  #2  
Old 06-09-2014, 08:23 PM
Molson02536 Molson02536 is offline
Senior Member
Drives a
 
Join Date: Dec 2009
Location: K/W Ontario Canada
Posts: 3,125
Send a message via AIM to Molson02536 Send a message via Yahoo to Molson02536
Cool

Quote:
Originally Posted by wurthit4660 View Post
New to the Gmc world so go easy on me... just picked up an 02' envoy sle, when I go to put it in 4wd low, high, or AWD I can hear what seems to be it engaging, however the service 4wd light comes on. Also when in one of the
4wd positions the light blinks (not sure if that is the norm or an indicator of something wrong). when I had it in 4wd low only my back tires spun in really muddy conditions. When I turn the vehicle off the service 4wd light goes off and stays off when the vehicle is re-started. service light only coming on when I attempt to use any of the 4wd options.

So is this a sign that I need a new 4wd transfer shift motor? or is it a different problem? Could use some help on this one thanks in advance....
Good chance the front axle discontent has gone bad. There common to go bad and costly to replace. If your lucky, it may just be the wire harness that has gone bad and will need to be replaced or fixed.

The front axle discontent is located on the passenger side. If your luck, it may just be a bad actuator witch is located on the front axle discontent it self. Check to see if there are any damaged wires or the actuator is damaged it self. But as mentioned, in most case your going to have a bad axle discontent.

Keep us posted and start with the simple and check your 4wd fuses to mkae sure there still good, under the hood and the rear seat on the driver's side.

Molson02536
Reply With Quote
  #3  
Old 06-13-2014, 10:19 PM
wurthit4660 wurthit4660 is offline
Junior Member
Drives a
 
Join Date: Jun 2014
Posts: 4
Default

Quote:
Originally Posted by Molson02536 View Post
Good chance the front axle discontent has gone bad. There common to go bad and costly to replace. If your lucky, it may just be the wire harness that has gone bad and will need to be replaced or fixed.

The front axle discontent is located on the passenger side. If your luck, it may just be a bad actuator witch is located on the front axle discontent it self. Check to see if there are any damaged wires or the actuator is damaged it self. But as mentioned, in most case your going to have a bad axle discontent.

Keep us posted and start with the simple and check your 4wd fuses to mkae sure there still good, under the hood and the rear seat on the driver's side.

Molson02536
For sure will check the fuses, then move onto the actuator. Is there a certain way I can tell if it is working/not working? Looks easy to change out do you undo it and see if it's functioning that way or what? Thanks Molson for the info
Reply With Quote
  #4  
Old 02-07-2019, 10:26 AM
blademan1972 blademan1972 is offline
Junior Member
Drives a 2007 GMC Envoy with 4.2L and a 1999 GMC Sierra 2500 4x4
 
Join Date: Dec 2018
Location: Fort Wayne Indiana
Posts: 3
Post Just went through this !

I just went through this with my wifes 07 envoy if you change the front actuator or the trasfercase motor be sure to go to the GMC dealership to get those 2 parts found out the expensive way that for some reason the envoy does not work well with after market parts I bought both of those parts at Napa and then started to have more problems than before i changed them apparently the 4x4 computer has problems communicating with after market acuators but since they are electrical parts once u install them you cant take them back so not only did i have to shell out almost $700.00 for the OEM parts at dealership but had to eat the cost of the Napa ones because they could not be returned the after market parts causes a feedback in the 4x4 system and turns on the service 4x4 light and puts the 4x4 system in limp mode witch is 4 Low and every thing stays engaged and wont let the truck go faster than about 8mph the only thing that will get the envoy out of limp mode is to pull the 4x4 fuse under the hood !
Reply With Quote
  #5  
Old 02-07-2019, 10:29 AM
blademan1972 blademan1972 is offline
Junior Member
Drives a 2007 GMC Envoy with 4.2L and a 1999 GMC Sierra 2500 4x4
 
Join Date: Dec 2018
Location: Fort Wayne Indiana
Posts: 3
Default

the front actuator makes a distinctive loud buzz then it activates if it doesn't make any noise at all its not working ! trust me I have been fighting with my envoy for over a year and have learned a lot put OEM parts in it and havent had a problem in 3 months !
Reply With Quote
Reply
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 11:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. 2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.