Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!


gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles No Longer In Production > GMC Jimmy Forum

Advertisements
cars connected social network






Notices

GMC Jimmy Forum Forum for discussions regarding the GMC Jimmy


GMC Forum: Hey yall, 2000 jimmy heeellllp?
Reply
 
Thread Tools
  #1  
Old 07-13-2018, 05:54 PM
Nick_200321 Nick_200321 is offline
Junior Member
Drives a GMC Truck
 
Join Date: Jul 2018
Posts: 2
Default Hey yall, 2000 jimmy heeellllp?

Hey guys, I'm nick I'm new here. I have a 2000 gmc jimmy which is giving me some issues. Was really hoping someone can point me in the right direction before just throwing money at it.

Ok here it goes. Vehicle has around 122k on it. When I bought it, only about 2k miles ago, it had a misfire but nothing terrible. Ran good, sometimes hard to start but once it started it ran decent. shifted good ect. Well out of the blue I started it and the abs light came on, once I started moving the parking brake light came on, speedometer wasn't working, and it wouldn't shift out of first gear. After like 30 seconds all the lights shut off, speedometer started working again and it shifted just fine. Now it's stuck in the lights on won't shift mode.

The only real back history I have is the guy who owned it before drove it through a flood and ever since then had multiple problems. Which I didn't find out until after I bought it. My thinking was the ecu became corroded and has now pooped out on me? But I'm not too sure. Anyone else ever see anything like this or know what I should look for? Please, any help or ideas would be appreciated. Thank you in advance and I hope I can help others sometime!
Reply With Quote

  #2  
Old 07-18-2018, 07:34 PM
GMC Forum GMC Forum is offline
Administrator
Drives a nothing at the moment...
 
Join Date: Nov 2008
Location: Royal Palm Beach, Florida
Posts: 713
Default

Quote:
Originally Posted by Nick_200321 View Post
Hey guys, I'm nick I'm new here. I have a 2000 gmc jimmy which is giving me some issues. Was really hoping someone can point me in the right direction before just throwing money at it.

Ok here it goes. Vehicle has around 122k on it. When I bought it, only about 2k miles ago, it had a misfire but nothing terrible. Ran good, sometimes hard to start but once it started it ran decent. shifted good ect. Well out of the blue I started it and the abs light came on, once I started moving the parking brake light came on, speedometer wasn't working, and it wouldn't shift out of first gear. After like 30 seconds all the lights shut off, speedometer started working again and it shifted just fine. Now it's stuck in the lights on won't shift mode.

The only real back history I have is the guy who owned it before drove it through a flood and ever since then had multiple problems. Which I didn't find out until after I bought it. My thinking was the ecu became corroded and has now pooped out on me? But I'm not too sure. Anyone else ever see anything like this or know what I should look for? Please, any help or ideas would be appreciated. Thank you in advance and I hope I can help others sometime!
Welcome aboard! And thank you for signing up. Sorry to hear you're having electrical troubles. Those seem to be the worst these days - the way automobiles have become so complex. I wish there were more Jimmy owners here. Have you figured anything out yet?
__________________
Want to be connected with everything automotive in your area? Check out the Cars Connected app today!


Get your next GMC for the lowest price possible! Go to TrueCar.com first!
Reply With Quote
  #3  
Old 07-21-2018, 05:47 PM
Nick_200321 Nick_200321 is offline
Junior Member
Drives a GMC Truck
 
Join Date: Jul 2018
Posts: 2
Default

Quote:
Originally Posted by GMC Forum View Post
Welcome aboard! And thank you for signing up. Sorry to hear you're having electrical troubles. Those seem to be the worst these days - the way automobiles have become so complex. I wish there were more Jimmy owners here. Have you figured anything out yet?
No I haven't figured anything out yet, been looking and looking. Hunting down electrical connectors but see no bad wires, no corrosion in the plugs, no bad grounds. All fuses look good. I'm so lost. It starts and runs great so I'd hate to get rid of it for a pesky electrical issue. I'd imagine it's not a shift solenoid, as I don't see that throwing my ABS or parking brake light on. Nor would it stop the speedometer from working. I just need some more ideas for what to check/where to look.
Reply With Quote
Reply
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:21 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.