Sign up to remove ads. We'd love to have you amongst our ranks! Just Click here!


gmc forums   gmc forums


Go Back   GMC Forums > GMC Vehicles Currently In Production > GMC Yukon Forum

Advertisements
cars connected social network






Notices

GMC Yukon Forum Forum for discussions regarding the GMC Yukon


GMC Forum: 2009 GMC Yukon Denali XL - Electrical Problems
Reply
 
Thread Tools
  #1  
Old 09-06-2016, 06:48 PM
JDubb1975's Avatar
JDubb1975 JDubb1975 is offline
Junior Member
Drives a 2009 GMC Yukon Denali XL
 
Join Date: Sep 2016
Location: Highland Village, TX
Posts: 2
Question 2009 GMC Yukon Denali XL - Electrical Problems

First off, I realize that this has been a very big issue for A LOT of owners having scoured the entire internet for causes and solutions with answers all over the place. I figured I would try and start up a dialogue with some well-informed folks and see if I can get a more reliable diagnosis here than YouTube or at least someone who can point me in the right direction.

Here is my issue/set of issues, all while driving:

- Cruise Control works intermittently.
- Side Blind Zone System Unavailable error message appears and disappears randomly (usually for several minutes at a time).
- Sometimes while accelerating the vehicle lurches and the airbag indicator flashes several times. This is usually the precursor to an extremely wild electrical fit.
- All doors begin locking and unlocking, in quick successive bursts, very randomly.
- Loss of ability to accelerate. The engine revs but the transmission seems to disengage.
- Radio console shuts of suddenly and goes black, usually turns itself back on.
- AC shuts off and when it comes back up, the temperature has reset to 74 degrees. Sometimes at this point the vents will not blow cold, sometimes the heater is blowing, and there have even been instances where heat and ac are blowing alternately from the driver/passenger vents.
- Often while this is all going on the battery voltage drops significantly.

All of these issues usually happen together, randomly, and after the truck has been driven for some time...usually not right out of the driveway. The only solution I have found so far is to pull over, stop the truck, and let it sit a while. However, sometimes when I do this the truck will not start...it is completely dead...even the dome lights. Sometimes I can let it sit a couple of minutes and it will start right up, and then sometimes it has to sit for 30 minutes before coming back to life.

I have had the battery and alternators tested - tested fine. I have also cleaned, greased and reseated all of the battery related contacts (battery terminals, mega fuse, main junction fuse seats and stabs, and the negative ground where it terminates near the front of the frame.) I have read countless messages where people have replaced batteries, battery cables, ground wires, door modules, ECMs and BCMs all with varying degrees of temporary and permanent success.

Has anyone encountered this issue that truly understands the root cause and the solution? Am I dealing with one issue or a few? Also, is there a GMC certified mechanic here knows how to fix this? Should I trade this sucker in and get a minivan or a non-power everything model? I am very frustrated, don't have unlimited time and money to chase this around.

Any well-informed help would be greatly appreciated.

Thanks!
Reply With Quote

  #2  
Old 11-02-2016, 12:06 PM
07denali 07denali is offline
Junior Member
Drives a GMC Truck
 
Join Date: Nov 2016
Posts: 1
Default

Mine is a 07 Yukon Denali xl 6.2 v8. Won't start, everything that basically runs off the keyfob has no power. I made a YouTube video showing my issues. I still hadn't figured it out. I've been searching all over the net, forums etc.

https://youtu.be/qSJrdQQ6C6Y
Reply With Quote
  #3  
Old 11-07-2016, 04:22 PM
zell66 zell66 is offline
Junior Member
Drives a
 
Join Date: Mar 2014
Posts: 18
Default

Our 07 Yukon had many of those issues, A/C, Headlights fluctuation or pulsing, and so on. Voltage was high and low, basically all over the place. I put in a new alternator and ALL problems went away. Hope this helps.
Reply With Quote
Reply

Tags
battery, electrical issues, side blind zone unav, yukon denali
Registered members see less ads. Please sign up! We'd love to have you...

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:00 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
gmcowners.com recognizes that "GMC", it's logos and various model names and numbers are registered trademarks of the General Motors Corporation. These terms are used for identification purposes only. gmcowners.com is not affiliated in any way with the General Motors Corporation, GMC or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on GMCOwners.com requires permission for reprint.


MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your GMC Truck? Check out your options at the links below:

Looking for something a little sporty? Believe it or not, Kia may have something for you. The Kia Stinger is a large sport-oriented hatchback sedan in the mold of the Audi A7.