battery

  1. W

    No radio after battery disconnect

    Long story, went to replace a/c blend actuator... couldn't reach it. So there was a link to disconnecting the battery to recalibrate a/c blend actuator. I did so, a/c works great now. However, not radio power anymore. Help! Couldn't find a fuse under hood, one under dash looks fine. Unplugged...
  2. S

    2017 Acadia won't start

    My car has less than 5,000 miles on it and I had to have the roadside assistance people send out a truck today to jump it for the third time in two weeks. I checked to make sure all of the dash lights were off before going into church this morning and then when I came out an hour later all of...
  3. JDubb1975

    2009 GMC Yukon Denali XL - Electrical Problems

    First off, I realize that this has been a very big issue for A LOT of owners having scoured the entire internet for causes and solutions with answers all over the place. I figured I would try and start up a dialogue with some well-informed folks and see if I can get a more reliable diagnosis...
  4. T

    03 yukon wiring problems

    Okay, so I have a 2003 yukon SLT and the problem I've been having is the stock head unit drains the battery, If I even plug it into the wiring harness and it's not on I t will drain the battery almost instantly. I even bought a new Pioneer head unit with a wiring harness with chimes and stuff to...
  5. C

    Electronic Mgmt System keeps alternator from charging battery

    I have installed an aftermarket audio head unit, amp, speakers and subwoofer in my 2012 Sierra 1500. Nothing big, just a 900 watt amp. Everything is properly wired. The problem is with the electronic power mgmt system which allows the alternator to disengage when the battery doesn't require...
  6. F

    Battery not receiving charge from alternator... Help!

    I could tell my alternator was going bad. Dash lights started to flicker, lost guages, car didn't turn back on. I replaced the alternator with a used one as I don't want to spend 200.00 on a new one, and it seemed fine, reading 14 amps... But then, next time I turned it on, it read 11.5/12...
  7. C

    1999 jimmy slt power locks blown!

    The alarm on my 1999 Jimmy SLT 4WD went off at 5AM today (in my absence) until the battery died. I'm 93% sure I locked doors upon parking yesterday, yet they were unlocked after the incident. Not sure if foul play or malfunction is afoot. The power locks no longer work by either remote (with...
Top