2015 Sierra 8 Speed Trans Issues

Smoke244

New member
Joined
Mar 6, 2021
Messages
2
Reaction score
0
Points
1
I purchased my 2015 GMC Sierra Denali used almost a year ago and I am experiencing delay shifting when cold going into reverse or drive and also have hard shifting from 1st to 2nd while the transmission is cold. On occasion I also am experiencing a hard downshift.

I have dicussed this with my dealer and I’m told this is normal for these 8 speed transmissions. The fluid has been recently changed.

is everyone just dealing with this or is there a fix for this?
 
G

G-597660

I purchased my 2015 GMC Sierra Denali used almost a year ago and I am experiencing delay shifting when cold going into reverse or drive and also have hard shifting from 1st to 2nd while the transmission is cold. On occasion I also am experiencing a hard downshift.

I have dicussed this with my dealer and I’m told this is normal for these 8 speed transmissions. The fluid has been recently changed.

is everyone just dealing with this or is there a fix for this?
Same problem with my 2016.
 

Dan_in_WA

New member
Joined
Dec 23, 2020
Messages
1
Reaction score
0
Points
1
Had the same problem in my wife’s ‘01 Montana.

The fix was to order a kit from TransGo for that particular transaxle, it had an oversized rubber seal that fit around a (IIRC) piston inside the trans.

Cold weather caused the original seal to contract enough that the fluid would leak past it. Until the transmission warmed up a bit, no reverse!

The TransGo seal fixed it completely.


Scroll down to the bottom of the page and find your transmission on the list.
 
Last edited:
Top