Hard start after truck is warm

04yellowjimmy

New member
Joined
Nov 22, 2017
Messages
2
Reaction score
0
Points
0
Hello, im new to this forum and have been having this problem for the past few months. truck starts good cold after sitting overnight. If i go for a drive for a half hour then shut the truck off for 20 mins and go to start it, it takes a few seconds longer to start then runs good. if i run the key to on and do that three times it starts good too. its a normal crank every time never slugish.

work thats been done the past year:

regular oil changes
plugs cap rotor
brand new spider
fuel pressure tested for the pimp and regulator and both were good
new engine coolant sensor map sensor
fuel filter
cleaned maf sensor
check for vaccum leaks
new o2 sensors
battery
starter

im stumped sorry for the long post
 

Jason6937

New member
Joined
Dec 26, 2016
Messages
27
Reaction score
0
Points
1
Maybe check the distributor for excessive play in the gears and replace it. Possibly needs the timing tightened up a bit
 

Kess

New member
Joined
Oct 27, 2017
Messages
14
Reaction score
0
Points
0
Location
Virginia
I'm having same problem on a 2000 Jimmy 4.3 Vortec,,,but. have not changed the Spider,,,don't believe it is bad, have good pressure and holds pressure for over a hour. Starting to think what Jason said, timing could be a little off..
Sure is frustrating.....
 

Kess

New member
Joined
Oct 27, 2017
Messages
14
Reaction score
0
Points
0
Location
Virginia
On my 2000 Jimmy wih hard start after warm problem,,,mechanic has tried spraying cool on the PCM, (computer), and it starts right up afer warm,,when cold, if you apply heat to PCM, it is hard starting...Have sent PCM to A-1, and got it back, same problem...Wondering if they checked it when hot? or warm? Think will send back to them.
 
Top