No ignition after jumping fuel pump relay and shorting

Megafox

New member
Joined
Nov 25, 2017
Messages
4
Reaction score
0
Points
0
I had no fuel pressure and finally jumped the relay with a paperclip but first I touched the wrong place then I found the one that worked but after getting 60 psi realized I now blew something else.
The only thing I touched was where the relay plugged in matching the wrong one first , I'm looking for what I blew or burned. Then I'm going to try to start it again to see if the fuel pump will keep running without burning up the ecm if it's any good at all. I heard that it is supposed to get less from the ecm but I did get to 60psi and wondering if I need a spider but can't check now , but it was running barely before I fried something , maybe a fuse and always started with a prime. I suspect ignition switch fuzes ecm and spider but I put new distributor before this and new fuel pump also has a vent door actuator that ran off and on.but it just ran rough like fuel issues never had over 12 psi before that part is temporarily solved I guess probably with too much voltage but seen them run.at least for awhile?
 

Megafox

New member
Joined
Nov 25, 2017
Messages
4
Reaction score
0
Points
0
I had no fuel pressure and finally jumped the relay with a paperclip but first I touched the wrong place then I found the one that worked but after getting 60 psi realized I now blew something else.
The only thing I touched was where the relay plugged in matching the wrong one first , I'm looking for what I blew or burned. Then I'm going to try to start it again to see if the fuel pump will keep running without burning up the ecm if it's any good at all. I heard that it is supposed to get less from the ecm but I did get to 60psi and wondering if I need a spider but can't check now , but it was running barely before I fried something , maybe a fuse and always started with a prime. I suspect ignition switch fuzes ecm and spider but I put new distributor before this and new fuel pump also has a vent door actuator that ran off and on.but it just ran rough like fuel issues never had over 12 psi before that part is temporarily solved I guess probably with too much voltage but seen them run.at least for awhile?

Ok now I'm going to go look for a blown fuse to the ignition I'm hoping I blew.
If I get ignition again I'll explain what not to do when jumping the fuel pump relay.and tell you what burns if I can find it.
 

Megafox

New member
Joined
Nov 25, 2017
Messages
4
Reaction score
0
Points
0
Ok now I'm going to go look for a blown fuse to the ignition I'm hoping I blew.
If I get ignition again I'll explain what not to do when jumping the fuel pump relay.and tell you what burns if I can find it.

1 day later .. ok I found the fuse 15amp next to the relay was ecm1 fuse moved around the relays and got ignition and 60 psi without a jumper in the relay box truck fires up pops and hisses seems starved for fuel ...gas gauge reads 0 but have 5 call ns or so fuel pressure is good
Ignition fires truck runs barely then pops and hisses backfires too .as it dies. But starts again Everytime with low rpm may idle a but seems like 3 cylinders maybe get fuel highly suspect injection and wonder if the recall will cover it in the condition it's in.
 

Megafox

New member
Joined
Nov 25, 2017
Messages
4
Reaction score
0
Points
0
1 day later .. ok I found the fuse 15amp next to the relay was ecm1 fuse moved around the relays and got ignition and 60 psi without a jumper in the relay box truck fires up pops and hisses seems starved for fuel ...gas gauge reads 0 but have 5 call ns or so fuel pressure is good
Ignition fires truck runs barely then pops and hisses backfires too .as it dies. But starts again Everytime with low rpm may idle a but seems like 3 cylinders maybe get fuel highly suspect injection and wonder if the recall will cover it in the condition it's in.
The recall also has free timing gears I think
 
Top