PLEASE HELP!! 1999 GMC Jimmy no start...

WgtKnightGdHart

New member
Joined
Dec 9, 2017
Messages
2
Reaction score
0
Points
0
I have a 1999 GMC Jimmy 4.3L Vortec. Did a basic Tuneup a few months ago, New Plugs, Wires, Dist cap and rotor. Last week I let it sit for two days when I was off work, went to start and it turns over but never starts, just pops and blows fuel and white smoke out of the throttle body as soon as you let off the key. pulled plugs and put in 5 new plugs,[they were fouled with fuel] charged the battery and turned the key... same problem, turns over great but still pops and spits fuel and white smoke up through throttle body. I have spark and I have fuel.

been told to replace fuel pump, fuel filter, spider injector, distributor, dist cap and rotor [again] ignition module, coil and MAF to fix it.... how could all of those things possibly have went bad letting it sit for two days? in ran great before that, no leaks, no oil in radiator, no coolant in oil [replaced the intake gaskets last summer] new fuel pump 2 years ago.:confused:

the only thing out of the ordinary in the two days before that, was a "Check Gauges" light that was intermittent. no engine light or codes.
 

WgtKnightGdHart

New member
Joined
Dec 9, 2017
Messages
2
Reaction score
0
Points
0
Ran a fuel pressure test, all was good. pulled distrib cap and it was all burnt from arcing, replaced cap and rotor and BINGO!!! back up and running!!!!!!!!
 

Jason6937

New member
Joined
Dec 26, 2016
Messages
27
Reaction score
0
Points
0
Make sure you have the wires going to the right plugs, this will co use a timing problem.
 
Top