power steering issue

huffy

New member
Joined
Feb 15, 2021
Messages
1
Reaction score
0
Points
1
Just purchased up a 2016 Canyon SLE with 20K miles - Has anyone have an intermittent power steering fail where the message flashes' on the dash and no power steering. Pulled and checked the fuse - reinstalled fuse and steering came back. Its happened 3 times and common denominator might be the extreme cold?
 

Musky

New member
Joined
Feb 24, 2021
Messages
1
Reaction score
0
Points
0
Yep I have it on my 2016 Canyon SLE (original owner). Seems to happen more in hotter months for me. I am in Ohio. I don't pull the fuse, just turn off, wait 5 seconds and turn on, most of the time this works, sometimes i need to do it a second time of off/on. In the last 12 month it has happened about 20 times. I don't think anyone knows the fix except replace everything associated with steering. I don't think it is mechanical, it is electronic issue. It could be a electronic issue in a mechanical part. I think a software fix is all that is needed. When the computes gets the signal it should not shut down the system that is a safety problem. It should just turn on the stability orange light.
 
G

G-982146

Thanks for that -

Mine is failing right at zero degrees when parked. Key cycling does not work - engine bay warms a little and then it will begin to work. I did order the steering module harness that goes low in the front mounted behind the steering gear / rack. After seeing the post with the open harness connectors down there full of sand and water I decided that is a very good place to start. 124.00 bucks and looks to be a shade tree day job with the front end up a little and drop the plastic pan shield. Harness about 16" log with 3 connectors at one end and 2 on the other - looks like plug and play once bottom of truck is open. Build some shielding?
 
Top